Ozdat Home Feature Cars Ozdat Classifieds Event Calander Links Trade Link Tech Resource Merchandise Donate Web Mail
It is currently Sun Jun 26, 2022 10:12 pm

All times are UTC+11:00




Post new topic  Reply to topic  [ 1 post ] 
Author Message
PostPosted: Thu Dec 16, 2021 12:37 pm 
Offline

Joined: Mon Dec 13, 2021 10:18 am
Posts: 1
Hey folks,

New here very happy to find a site in Oz for Datsun's/old Nissan's (or at least I hope the Urvan is welcome here :D )

I picked it up last night knowing it had some issues and this is what i noticed . . .

The fan is really loud on pull away 1st, 2nd gear . . . then it quietens down. Every time I stopped at a set of traffic lights the temp gauge started climbing up to half way and just past in some instances, and no sign of the fan shifting to a higher speed?? Along the highway though the temp gauge stayed about a 1/3 of the way. When I spin the fan by hand (engine off cooled down) it stops as soon as my finger leaves the blade almost. I've checked the oil and coolant for any signs of head gasket damage and both look ok. Thinking if it's not the fan perhaps it's the thermostat.

What brand water pumps and fan clutches are people using in Australia?


Attachments:
[ attachment ]
Urvan.jpg [ 143.91 KiB | Viewed 189 times ]
Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 1 post ] 

All times are UTC+11:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to: 

Powered by phpBB® Forum Software © phpBB Limited